[HOW TO] iPod Touch su Linux

Come sincronizzare l'iPodTouch Jailbreakato con Amarok. Potete farlo anche voi seguendo questa "semplice" procedura (nell'attesa di iTunes per Linux):

1. Vai su iSpazio e jailbreakka l'iPod con la versione 1.1.2 del firmware (trovi tutto su i tutorial)

2. Installa il pacchetto "BSD Subsystem" dall'installer dell'iPod



3. collegati con ssh su root@indirizzo.ip.del.ipod, e edita /etc/sshd_config (nano, vi, vim sono disponibili), e abilita l'rsa public key authentication

4. crea una chiave rsa per ssh senza password

5. copia l'id di ssh sul tuo indirizzo root@indirizzo.ip.del.ipod

6. riavvia sshd sull'iPod (dall'icona "SSH" che trovate nel launcher)

7. Installa sulla tua linuxbox: fuse, sshfs-fuse, e la più recente libreria libgpod

8. sudo mkdir /mnt/ipod; sudo chmod 755 /mnt/ipod

9. Monta l'iPod con "sshfs root@indirizzo.ip.del.ipod:/var/root/Media /mnt/ipod" (o media in relazione alla tua distro)

10. cd /mnt/ipod (o media in relazione alla tua distro)

11. ln -s iTunes_Control iPod_Control

12. cd iPod_Control/Device

13. sudo lsusb -v -d 05ac: | grep iSerial | awk '{print $3}' | cut -b1-16 | xargs printf "FirewireGuid: 0x%sn" > SysInfo

14. Esci da /mnt/ipod

15. fusermount -u /mnt/ipod

16. Apri Amarok, e apri il pannello di configurazione dei dispositivi (Settings->Configure->Media Devices)

17. Aggiungi un nuovo iPod, con /mnt/ipod (oppure /media/ipod, dipendentemente dalla tua distro)

18. Clicca sul tab dell'iPod dalle preferenze

19. Imposta sul box "Pre-connect command" la seguente striga "sshfs -o workaround=rename root@indirizzo.ip.del.ipod:/var/root/Media /mnt/ipod" ("workaround=rename" aggiusta il problema con l'album delle copertine).

20. In "Post-connect command", scrivi "fusermount -u /mnt/ipod"

21. Usa il pannello "Devices" di Amarok per sincronizzare la tua musica - ricorda che quando sincronizzi la musica devi uscire e riaprire l'applicativo per leggere musica sull'iPod (aprilo, e premi il bottone tondo "Home" fino a quando il programma non sparisce)

Se usi una distribuzione a 64-bit, avrai bisogno di una piccola patch per libgpod.

Ringrazio RS8000 per le dritte, cliccate pure sul suo nik per leggere la sua guida originale in inglese che magari per qualcuno si capira meglio della mia traduzione -_-'
LOL :D