Firefox tuning!

Quello che sto per dirvi sono delle semplici impostazioni del nostro caro e amato browser che l'utente medio non conosce o ignora:

Velocizzare Firefox:

Per velocizzare il caricamento delle pagine possiamo aumentare il numero max di connessioni consentite dal browser andando su about:config (digitiamolo sulla barra dell'indirizzo)

possiamo cambiare i seguenti valori

network.http.max-connections
impostiamo il valore integer a 128
network.http.max-connections-per-server impostiamo il valore integer a 48
network.http.max-persistent-connections-per-proxy impostiamo il valore integer a 24
network.http.max-persistent-connections-per-server impostiamo il valore integer a 12

questi valori sono indicativi a vari esperimenti e quindi possono essere variati a piacimento, su questa pagina poi c'e' una mole di impostazioni su cui potrete divertirvi! :P

Ingannare i siti internet:

Vi e' mai capitato di entrare su un sito che richieda IE? O volete seplicemente figurare diversamente o in modo simpatico nelle statistiche dei siti internet?
tornando sulla pagina delle impostazioni che vi ho descritto prima (about:config) aggiungiamo una nuova stringa (menu' a tendina con tasto dx New -> String) dal nome

general.useragent.override

e all'interno digiteremo una cosa simile a :

Mozilla/5.0 (compatible;MSIE 7;Windows NT 5.1)

Ma ovviamente lasciamo spazio alla fantasia e alle esigenze!!

ENJOY! =)

Commenti

emil ha detto…
ciao, post interessante, non conoscevo questa funzione e mi torna molto utile, solo che non funziona a sufficienza. Ho cercato anche sul sito di Mozilla, ma niente. Con un'applicazione stupida (di quelle che ti dicono l'ip pubblico,ecc.) vedo che effettivamente il mio browser figura come explorer 6,7 o quel che è, ed eseguito su win xp, ma un sito (dell'università di padova) continua a notificarmi che devo usare explorer per determinate funzioni. Bisogna cambiare anche qualche altra opzione? Io ci ho provato, ma magari sbagliavo. Oppure in certi casi non c'è niente da fare? a questo punto sembra quasi strano che non si riesca ad imbrogliare quel maledetto server. Sai darmi qualche indicazione in più? So che Opera e Konqueror non soffrono di questa "incompatibilità", ma in questo momento non ho modo di verificare che impostazioni hanno (credo che about:config si possa dare lo stesso giusto? su epiphany sì, ad esempio). Grazie in anticipo, ciao!

P.S.:correggi MISE in MSIE, deve esserti scappato.
HK4life ha detto…
Ciao emil!
Intanto grazie mille della dritta non me ne ero proprio accorto del MISE - MSIE!
IE 7 dovrebbe identificarsi con: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1)
Dico dovrebbe perche' ora non ho macchine sottomano con win installato :P
Bisogna capire per quali tipo di operazioni il sito dell'uni di padova ti mostra la famosa notifica, se risponde a dei componenti activex o cose del genere...
C'e' chi usa, per tagliare la testa la toro, IE4linux, ma risulta poco stabile e poi chi lo vuole IE su linux? Forse solo un web designer!
Ma per i piu' affezionati a Firefox, non saprei cosa consigliare!
Cmq su Opera c'e' opera:config su Konqueror non saprei!

In questi gg faro' delle prove anche con IE per vedere se cambia qualcosa a livello di identificazione, sappimi dire qualcosa di piu' sul portale di padova!
emil ha detto…
Ciao, intanto questo è un post in cui mesi fa mi lamentavo del sito dell'università:
http://emilator.wordpress.com/2007/09/10/luniversita-di-padova-va-matta-per-internet-explorer/
E' un portale dove si accede per effettuare iscrizioni, ecc..
la stringa che hai scritto è giusta, oggi ne ho provate diverse, pure che firefox figurasse come IE 7 su Mac, ma niente, c'è qualcosa di più sotto che non conosco.
Ho anche avuto modo di provare konqueror, che a differenza di firefox,epiphany,galeon,kazehakase e chi più ne ha più ne metta non gira su gecko bensì su khtml. konqueror ha pure un'interfaccia per quelle impostazioni, molto comoda, ho copiato quelle ma niente da fare.
Comunque la mia era più che altro curiosità, riuscire a gabbare il server sarebbe divertente. Riuscire a bucarlo (ha una versione vulnerabile di ssl) sarebbe ancora più divertente. Di sicuro dopo lo aggiornano!
HK4life ha detto…
hehehe! Hai ragione!!!

Post più popolari